Wiki

This version is outdated by a newer approved version.DiffThis version (24 Jul 2012 15:32) was approved by DragosB.The Previously approved version (11 Jul 2012 09:10) is available.Diff

This is an old revision of the document!


AD7303 - Microcontroller No-OS Driver

Supported Devices

Evaluation Boards

Overview

The AD7303 is a dual, 8-bit voltage out DAC that operates from a single +2.7 V to +5.5 V supply. Its on-chip precision output buffers allow the DAC outputs to swing rail to rail. This device uses a versatile 3-wire serial interface that operates at clock rates up to 30 MHz, and is compatible with QSPI, SPI, microwire and digital signal processor interface standards. The serial input register is sixteen bits wide; 8 bits act as data bits for the DACs, and the remaining eight bits make up a control register.

The goal of this project (Microcontroller No-OS) is to be able to provide reference projects for lower end processors, which can't run Linux, or aren't running a specific operating system, to help those customers using microcontrollers with ADI parts. Here you can find a generic driver which can be used as a base for any microcontroller platform and also specific drivers for Renesas platforms.

HW Platform(s):

Driver Description

The driver contains two parts:

  • The driver for the AD7303 part, which may be used, without modifications, with any microcontroller.
  • The Communication Driver, where the specific communication functions for the desired type of processor and communication protocol have to be implemented. This driver implements the communication with the device and hides the actual details of the communication protocol to the ADI driver.

The Communication Driver has a standard interface, so the AD7303 driver can be used exactly as it is provided.

There are three functions which are called by the AD7303 driver:

  • SPI_Init() – initializes the communication peripheral.
  • SPI_Write() – writes data to the device.
  • SPI_Read() – reads data from the device.

SPI driver architecture

The following functions are implemented in this version of AD7303 driver:

Function Description
unsigned char AD7303_Init(void) Initializes the SPI communication peripheral.
void AD7303_Write(unsigned char controlReg, unsigned char dataReg) Sends data to AD7303.

Downloads

Renesas RL78G13 Quick Start Guide

This section contains a description of the steps required to run the AD7303 demonstration project on a Renesas RL78G13 platform.

Required Hardware

Required Software

Hardware Setup

A PmodDA1 has to be connected to the PMOD1 connector.

Software Setup

With the Applilet3 for RL78G13 tool the following peripherals have to be configured:

CSI10 (Clocked Serial Interface 10) – For the AD7303 part and the ST7579 LCD

Choose to generate the Transmit/receive function for the CSI10 and configure the interface with the following settings:

  • Transfer mode setting: Single transfer mode
  • Data length setting : 8 bits
  • Transfer direction setting: MSB
  • Specification of data timing: Type 1
  • Transfer rate setting – Clock mode: Internal clock (master)
  • Transfer rate setting – Baudrate: 1000000 (bps)
  • Interrupt setting – Transfer interrupt priority (INTCSI10): Low
  • Uncheck the callback functions.

TM00 (Timer 00) – For the DelayMs() function

Configure TM00 as an interval timer:

  • Interval timer setting - Interval value(16 bits): 1 ms
  • Interval timer setting - Uncheck Generates INTM00 when counting is started
  • Interrupt setting - Uncheck End of timer channel 0 count, generate an interrupt (INTM00)

Watchdog Timer

Disable the watchdog timer:

  • Choose for the Watchdog timer operation setting: Unused option.

Reference Project Overview

The reference project outputs a 3 Hz sinewave on channel A and a specific value every second on channel B.

Software Project Tutorial

This section presents the steps for developing a software application that will run on the Renesas Demo Kit for RL78G13 for controlling and monitoring the operation of the ADI part.

Two software applications have to be used: Applilet3 for RL78G13 (a tool that automatically generates device drivers for MCU peripheral functions) and IAR Embedded Workbench for Renesas RL78 (the integrated development environment).

Step 1 - Applilet3 for RL78G13

  • Run the Applilet3 for RL78G13 tool and create a new project for R5F100LE processor. Select IAR Compiler build tool, a project name, a location for the new project and press OK.

  • Keep the default Pin assignment setting and click Fix settings.

  • Now the desired peripherals can be configured and the code can be generated. For example, if the clocked serial interface 10 (CSI10) has to be configured, select the Serial peripheral, choose for the Channel 2 of Serial Array Unit 0 (SAU0) the CSI10 interface, Transmit/receive function option and then go to CSI10 tab.

  • To configure the CSI10 interface for serial transmissions of 8 bits, with MSB first, with the data captured on clock's rising edge, with a frequency of the clock of 1 MHz and the idle state high, the settings from the following image have to be made.

  • After all the desired peripherals are configured click on the Generate Code button and a new workspace and a new project for the IAR Embedded Workbench will be generated. After the code was generated close the Applilet3 for RL78G13 tool.

Step 2 - IAR Embedded Workbench for Renesas RL78

  • Run the IAR Embedded Workbench and open the workspace created with the Applilet3 tool.

  • Copy the files extracted from the zip file into the user_src folder, located in the project’s folder.

  • The new source files have to be included into the project. Add in the user_src group the files from the corresponding folder (Right click on the group and select Add – Add Files…). Because a new Main file was included the r_main.c file from the applilet_src group has to be deleted (Right click on the file and select Remove).

  • Now the debugger driver has to be selected from the project’s options. Right click on the project name and select Options. From the Debugger category choose the TK Debugger Driver.

  • Now, the project is ready to be compiled and downloaded on the board. Press the F7 key to compile it. Press CTRL + D to download and debug the project.

29 Feb 2012 17:01 · dragosb

Renesas RX62N Quick Start Guide

This section contains a description of the steps required to run the AD7303 demonstration project on a Renesas RX62N platform.

Required Hardware

Required Software

Hardware Setup

A PmodAD5 has to be interfaced with the Renesas Demonstration Kit (RDK) for RX62N:

  PmodDA1 Pin 1 (CS)   → YRDKRX62N J8 connector Pin 15
  PmodDA1 Pin 2 (MOSI) → YRDKRX62N J8 connector Pin 19
  PmodDA1 Pin 4 (CLK)  → YRDKRX62N J8 connector Pin 20
  PmodDA1 Pin 5 (GND)  → YRDKRX62N J8 connector Pin 4
  PmodDA1 Pin 6 (VCC)  → YRDKRX62N J8 connector Pin 3

Reference Project Overview

The reference project outputs a 3 Hz sinewave on channel A and a specific value every second on channel B.

Software Project Setup

This section presents the steps for developing a software application that will run on the Renesas Demo Kit for RX62N for controlling and monitoring the operation of the ADI part.

  • Run the High-performance Embedded Workshop integrated development environment.
  • A window will appear asking to create or open project workspace. Choose “Create a new project workspace” option and press OK.
  • From “Project Types” option select “Application”, name the Workspace and the Project “ADIEvalBoard”, select the “RX” CPU family and “Renesas RX Standard” tool chain. Press OK.

  • A few windows will appear asking to configure the project:
    • In the “Select Target CPU” window, select “RX600” CPU series, “RX62N” CPU Type and press Next.
    • In the “Option Setting” windows keep default settings and press Next.
    • In the “Setting the Content of Files to be generated” window select “None” for the “Generate main() Function” option and press Next.
    • In the “Setting the Standard Library” window press “Disable all” and then Next.
    • In the “Setting the Stack Area” window check the “Use User Stack” option and press Next.
    • In the “Setting the Vector” window keep default settings and press Next.
    • In the “Setting the Target System for Debugging” window choose “RX600 Segger J-Link” target and press Next.
    • In the “Setting the Debugger Options” and “Changing the Files Name to be created” windows keep default settings, press Next and Finish.
  • The workspace is created.

  • The RPDL (Renesas Peripheral Driver Library) has to integrated in the project. Unzip the RPDL files (double-click on the file “RPDL_RX62N.exe”). Navigate to where the RPDL files were unpacked and double-click on the “Copy_RPDL_RX62N.bat” to start the copy process. Choose the LQFP package, type the full path where the project was created and after the files were copied, press any key to close the window.
  • The new source files have to be included in the project. Use the key sequence Alt, P, A to open the “Add files to project ‘ADIEvalBoard’” window. Double click on the RPDL folder. From the “Files of type” drop-down list, select “C source file (*.C)”. Select all of the files and press Add.

  • To avoid conflicts with standard project files remove the files “intprg.c” and “vecttbl.c” which are included in the project. Use the key sequence Alt, P, R to open the “Remove Project Files” window. Select the files, click on Remove and press OK.

  • Next the new directory has to be included in the project. Use the key sequence Alt, B, R to open the “RX Standard Toolchain” window. Select the C/C++ tab, select “Show entries for: Include file directories” and press Add. Select “Relative to: Project directory”, type “RPDL” as sub-directory and press OK.

  • The library file path has to be added in the project. Select the Link/Library tab, select “Show entries for: Library files” and press Add. Select “Relative to: Project directory”, type “RPDL\RX62N_library” as file path and press OK.

  • Because the “intprg.c” file was removed the “PIntPrg” specified in option “start” has to be removed. Change “Category” to “Section”. Press “Edit”, select “PIntPRG” and press “Remove”. From this window the address of each section can be also modified. After all the changes are made press OK two times.

  • At this point the files extracted from the zip file located in the “Software Tools” section have to be added into the project. Copy all the files from the archive into the project folder.

  • Now, the files have to be included in the project. Use the key sequence Alt, P, A to open the “Add files to project ‘ADIEvalBoard’” window. Navigate into ADI folder. From the “Files of type” drop-down list, select “Project Files”. Select all the copied files and press Add.

  • Now, the project is ready to be built. Press F7. The message after the Build Process is finished has to be “0 Errors, 0 Warnings”. To run the program on the board, you have to download the firmware into the microprocessor’s memory.
03 Feb 2012 15:32 · dragosb

Digilent Cerebot MX3cK Quick Start Guide

This section contains a description of the steps required to run the AD7303 demonstration project on a Digilent Cerebot MX3cK platform.

Required Hardware

Required Software

Hardware Setup

A PmodDA1 has to be connected to the JE connector of Cerebot MX3cK development board.

Reference Project Overview

Following commands were implemented in this version of AD7303 reference project for Cerebot MX3cK board.

Command Description
help? Displays all available commands.
power= Powers off/on the current channel. Accepted values: 0, 1.
power? Displays the power status.
channel= Selects a channel. Accepted values: 0, 1.
channel? Displays the current channel.
voltage= Sets the output voltage of the current channel. Accepted values: 0→3.3
voltage? Displays last written value.
register= Writes to the DAC register of the current channel. Accepted values: 0 - 255.
register? Displays last written value.

Commands can be executed using a serial terminal connected to the UART1 peripheral of PIC32MX320F128H.

The following image shows a list of commands in a serial terminal connected to processor’s UART peripheral.

Software Project Setup

This section presents the steps for developing a software application that will run on the Digilent Cerebot MX3cK development board for controlling and monitoring the operation of the ADI part.

  • Run the MPLAB X integrated development environment.
  • Choose to create a new project.
  • In the Choose Project window select Microchip Embedded category, Standalone Project and press Next.

  • In the Select Device window choose PIC32MX320F128H device and press Next.

  • In the Select Tool window select the desired hardware tool and press Next.

  • In the Select Compiler window chose the XC32 compiler and press Next.

  • In the Select Project Name and Folder window choose a name and a location for the project.

  • After the project is created, all the downloaded source files have to be copied in the project folder and included in the project.

  • The project is ready to be built and downloaded on the development board.

05 Jul 2012 14:45

Digilent Cerebot MC7 Quick Start Guide

This section contains a description of the steps required to run the AD7303 demonstration project on a Digilent Cerebot MC7 platform.

Required Hardware

Required Software

Hardware Setup

A PmodDA1 has to be connected to the JB connector of Cerebot MC7 development board.

Reference Project Overview

Following commands were implemented in this version of AD7303 reference project for Cerebot MC7 board.

Command Description
help? Displays all available commands.
power= Powers off/on the current channel. Accepted values: 0, 1.
power? Displays the power status.
channel= Selects a channel. Accepted values: 0, 1.
channel? Displays the current channel.
voltage= Sets the output voltage of the current channel. Accepted values: 0→3.3
voltage? Displays last written value.
register= Writes to the DAC register of the current channel. Accepted values: 0 - 255.
register? Displays last written value.

Commands can be executed using a serial terminal connected to the UART1 peripheral of dsPIC33FJ128MC706A.

The following image shows a list of commands in a serial terminal connected to processor’s UART peripheral.

Software Project Setup

This section presents the steps for developing a software application that will run on the Digilent Cerebot MC7 development board for controlling and monitoring the operation of the ADI part.

  • Run the MPLAB X integrated development environment.
  • Choose to create a new project.
  • In the Choose Project window select Microchip Embedded category, Standalone Project and press Next.

  • In the Select Device window choose dsPIC33FJ128MC706A device and press Next.

  • In the Select Tool window select the desired hardware tool and press Next.

  • In the Select Compiler window chose the XC16 compiler and press Next.

  • In the Select Project Name and Folder window choose a name and a location for the project.

  • After the project is created, the source files have to be copied in the project folder and included in the project.

  • The project is ready to be built and downloaded on the development board.

16 Jul 2012 16:48

Digilent Cerebot MX3cK Quick Start Guide - Arduino

This section contains a description of the steps required to run the AD7303 Arduino demonstration project on a Digilent Cerebot MX3cK platform.

Required Hardware

Required Software

Hardware Setup

A PmodDA1 has to be connected to the JE connector of Cerebot MX3cK development board.

Reference Project Overview

Following commands were implemented in this version of AD7303 Arduino reference project for Cerebot MX3cK board.

Command Description
help? Displays all available commands.
power= Powers off/on the current channel. Accepted values: 0, 1.
power? Displays the power status.
channel= Selects a channel. Accepted values: 0, 1.
channel? Displays the current channel.
voltage= Sets the output voltage of the current channel. Accepted values: 0→3.3
voltage? Displays last written value.
register= Writes to the DAC register of the current channel. Accepted values: 0 - 255.
register? Displays last written value.

Commands can be executed using the serial monitor.

Carriage return has to be selected as a line ending character. The required baud rate is 9600 baud.

The following image shows a list of commands in the serial monitor.

Software Project Setup

This section presents the steps for developing a chipKIT application that will run on the Digilent Cerebot MX3cK development board for controlling and monitoring the operation of the ADI part.

  • Under your Sketchbook directory create a folder called “Libraries”; this folder may already exist.
  • Unzip the downloaded file in the libraries folder.
  • Run the MPIDE environment.
  • You should see the new library under Sketch→Import Library, under Contributed.

  • Also you should see under File→Examples the demo project for the ADI library.
  • Select the ADIDriver example.

  • Select the Cerebot MX3cK board from Tools→Board.
  • Select the corresponding Serial Communication Port from Tools→Serial Port
  • The project is ready to be uploaded on the development board.

23 Jul 2012 16:51

More information

01 Jun 2012 12:21
resources/tools-software/uc-drivers/renesas/ad7303.1343136768.txt.gz · Last modified: 24 Jul 2012 15:32 (external edit)