Wiki

This version (03 Jan 2024 13:17) was approved by Gowtham Lakshmikanthan.

FAQs on SigmaStudio+ and A2B:

General Q & A

Q: What is SigmaStudio+ software for A2B?

A: The SigmaStudio®+ is a graphical development tool for programming, development, and tuning the software for ADI A2B® transceivers. It is mainly used to create a schematic, Design and Validate the A2B network.

Note: Future A2B plugins update will be available for SigmaStudio+ only.

Q: What is A2B Plugin for SigmaStudio+?

A: The A2B Plugin Software is an add-on to SigmaStudio+ that enables the user to graphically model an A2B network, which facilitates quick evaluation and bring-up of the network with audio routing. Once the network is stabilized, the configuration can be exported into an embedded platform. The A2B stack uses this configuration and manages the A2B network.

Q: Where can I download SigmaStudio+?

A: The latest SigmaStudio+ release package can be downloaded from SigmaStudio®+ | Analog Devices.

Note: If you are using SigmaStudio+ 2.0.0, Please update the software to Update1(2.0.1) which is required for A2B -SigmaStudio+ Plugin 1.2.0. The SigmaStudio+ software update is available in “Help → Check For Updates”

Q: Where can I download the latest A2B plugin for SigmaStudio+?

A: Latest version of A2B plugin for SigmaStudio+ for Windows/BareMetal can be found on the Analog Devices Gated website under Software section A²B Technology | Analog Devices

Q: Where can I find an example schematic for an A2B network?

A: Example Schematics can be used to run a quick demo on PC using SigmaStudio+ and it is available in the following Path: C:\Analog Devices\ADI_A2B-SSPlus_Software-#version\Schematics\PC. The XML files to configure the Audio host and codecs can be found in C:\Analog Devices\ADI_A2B-SSPlus_Software-Relx.y.z\Schematics\PC\xml

Q: Where can I find the installation folders for A2B software, SigmaStudio+ on my PC?

A: For A2B Plugin Software: C:\Analog Devices\ADI_A2B-SSPlus_Software-#version For SigmaStudio+: C:\Analog Devices\SigmaStudioPlus-RelX.Y.Z

Q: Where can I find User Guides for setting up of A2B Network and SigmaStudio+?

A: Starting Guide for Setting up of A2B system using SigmaStudio+ quickly can be found in the installation path “C:\Analog Devices\ADI_A2B-SSPlus_Software-#version\Docs”. Soon it will be available part of analog.com

Note: Release notes for A2B plugin and license agreement documents (Click Thru ELA/SLA) can be found in C:\Analog Devices\ADI_A2B-SSPlus_Software-#version

Q: Is A2B SigmaStudio+ support migration of A2B Schematic from SigmaStudio to SigmaStudio+?

A: Migration of A2B Schematic from SigmaStudio to SigmaStudio+ will be supported in future releases.

Q: Can we import busconfig.xml file from SigmaStudio to SigmaStudio+?

A: Importing of busconfig.xml from SigmaStudio to SigmaStudio+ will be supported in future releases.

Q: How to set the order of programming of I2C peripherals while using SigmaStudio+?

A: The order of peripheral programming depends on which peripheral is dragged and dropped first from the toolbox. For example, if we have two peripherals Codec and EEPROM, the peripheral used for EEPROM is dragged and dropped first into the schematic, and the peripheral used for Codec is dragged and dropped later into the schematic, then EEPROM will be programmed first and followed by Codec.

Q: How do I open a SigmaDSP project from within the A2B project? This was easily done in SigmaStudio from the peripheral properties window, but I cannot seem to figure out how to do so in SigmaStudio+?

A: The idea with SigmaStudio+ is not to have a separate project for SigmaDSP but integrate the SigmaDSP schematic and configuration in the same project. So, there is no need to track it as a separate SigmaDSP project. If there is an integrated SigmaDSP schematic, then you can right click and select open schematic to see the SigmaDSP schematic. The xml generated for the SigmaDSP will be part of the settings of the project.

Q: How to ensure that Link Compile Download is successful or not?

A: You will the see A2B nodes turn green, and discovery successful message will be notified. Similarly when the platforms are double clicked the status is updated for Peripherals as well.

Common Errors:

Q: Why am I getting project invalid error while opening SigmaStudio+ project?

A: Please ensure that you have installed A2B Plugins before opening SigmaStudio+ Projects for A2B.

Q: Why am I getting “Unable to detect valid SigmaStudio+ version” error while installing A2B plugin even though the SigmaStudio+ software is installed?

A: Please ensure that you have the compatible version of SigmaStudio+ installed before installing A2B plugin. To Check for updates, go to “Help → Check For Updates”.

Q: Why am I getting “Target communication failed” error while downloading from SigmaStudio+?

A: Ensure the Target board is connected to the host (PC) through USBi properly and the local powered nodes are connected to power supply.

Q: What is “Authentication failure Error” during discovery of default schematic?

A: The error may occur due to the ‘Silicon Revision’ mismatch of the transceiver, you can update the settings of silicon revision or you can enable ‘Disable transceiver authentication’ option.

Q: After clicking the ‘Link-Compile’ button, Link-Compile-Download button is disabled, how to enable it?

A: Click anywhere in the SigmaStudio+ window to enable the button again.

Q: Why do we get the “Unknown error found during discovery” error while downloading the Schematic in SigmaStudio+?

A: This error occurs for the following scenarios,

• If the schematic is not saved before proceeding to download it to the target. Do Save the Schematic before downloading it to the target.

• If the peripherals connected to main node does not have the right address.

Check the output window for more details.

Q: What is “Main Running Interrupt Not Detected” error?

A: This error could be occurring due to below reasons:

• Please ensure that you have selected the proper XML file for the Audio host and that ‘Program during discovery ‘is enabled.

Q: What is the “I2C error at Main Node” error during discovery?

A: Please check the ‘Main Address(I2C)” in the Main Node and check the Jumper setting, which can be found in ‘A2B-SSPlus_Quick_Start_Guide’ available in the path “C:\Analog Devices\ADI_A2BSSPlus_Software-Relx.y.z\Docs”.

Q: SigmaStudio+ GUI is frozen when settings tab is accessed for an A2B node from Custom Platform Design?

A: This issue is specific to 1.2.1 release of A2B. Instead of adding sub shapes like main node, generic device in custom node, Export the shape contents of standard Nodes.

• Drag & drop required A2B nodes on the design canvas and save shape contents of standard platform to a file.

• Create custom platform and load shape contents (of standard platform) onto custom platform and then make required settings.

Q: I am getting “I2C Transaction error” during discovery with a .dat file generated for A2B Network containing 2433 main and sub nodes from SigmaStudio+?

A: In the A2B schematic, If the USBi is connected to the 2433 main node through I2C and if the 2433 sub-node contains SPI peripheral (EEPROM) then the above-mentioned error will be notified. I2C to remote SPI peripheral programming is not supported.

Q: After attempting SigmaStudio+ window open and close, main GUI has disappeared and only project window remains. When tried to open SigmaStudio+, only project window appears.

A: Please go to the folder “C:\Users\<your user name>\AppData\Roaming\SigmaStudio” and delete all the xml files starting with layoutDefault (layoutDefault*.xml). Now restart SigmaStudio+.

Q: Why am I getting “Custom Node Authentication failure” Error?

A: During A2B discovery process, the stack will read the Custom Identifier value from the remote memory device via I2C at the specified address/ read the GPIO status / read the custom node identifier value via mailbox registers and validate it against the assigned value. If there is a match, then the node will be successfully configured otherwise the discovery will be aborted.

Q: Where can I extract .dat file from SigmaStudio+, It is not found under export configuration?

A: The option to export the bus configuration dat file is under “EEPROM DUMP” tab of Export Import Settings window.

Q: After docking any window to title bar, it is unable to close the window.

A: Under View → Layout → Reset Layout can be provided. If this does not work, then delete layout file from “C:\Users\<your user name>\AppData\Roaming\SigmaStudio”. Delete all the xml files starting with layoutDefault (layoutDefault*.xml). Now restart SigmaStudio+.

Q: What is the below error on I2C Error Notification?

A: There is no Peripheral with Address 0x40 connected to sub node 1.

Q: What is the “active”, “error” and “design” indicated at the right end of SigmaStudio+ screen.

A: This is the current state of schematic where,

Active → Indicates Successful download

Error → Indicates there is failure during download

Design → Indicates the schematic is being currently updated

resources/tools-software/a2bv2/frequentlyaskedquestions.txt · Last modified: 03 Jan 2024 11:01 by Gowtham Lakshmikanthan