Step 1: Create a CCES plugin project

Open CCES. In the menu bar, click File->New->CrossCore Project. Input project name, for example,
Multi_tab_Delay, in Project Name. Users could designate any project directory in Location. Click Next.

" New CrossCore Project = @
General Project Information -
%
Specify the project name and its location. - —
Project name: Mu\t\,tap,Delaﬂ
Location: | Use default location
CAProjects\Multi_tap_Delay Browse...
@ < Back Finish Cancel

Choose SHARC in Processor family at the left column, and then select ADSP-SC589 in Processor type at the
right column, and select 1.0 in Silicon revision. Please note users should choose processor and silicon
revision that comply with hardware. Click Next.

7 Mew CrossCore Project = @

Processor Type -
%
Specify the family, type, and silicon revision of the processor that yvou would like for this B

project to target.

Processor family: Processor type:
ADSP-21587 o

B ADSP-5C570
ARM ADSP-5C57L
ADSP-5C572

ADSP-5C572
ADSP-5C582
EBlackfin ADSP-5C583
ADSP-5C584
ADSP-5C587
ADSP-5C58%

11l

m SHARC

Silicon revision:
0.1

any

none

Show processors from third party vendors

"'_’j‘ < Back Finish Cancel

Uncheck Create a project for core 0 and Create a project for core 2. Because we assume that the whole
audio module only runs on a single Sharc core, either Sharc core 1 or Sharc core 2.




" New CrossCore Praject = @

Projects and Settings

e

&
Specify the toolchain and settings that you would like to use for each ADSP-SC589 core project. - —

J Create a project for core 0

~ || Create a project for core 1

Toolchain: |CrossCore SHARC Toolchain 52

» Configuration Summary 5 Configure Project..

» Create a project for core 2

Finish ‘ ‘ Cancel ‘

'/?> < Back MNext >

Click Configure Project. Uncheck all Recommended Add-ins, Device Drivers and System Services, Software
Modules, etc. Click OK and come back to the previous dialog window. Click Finish. Then you should be able
to see a project named “Biquad_Corel” in the CCES Project Explorer window.

7 Core Settings ===

Specify configuration settings for core 1 project

Select the Add-ins to include in your project and generate skeleton code to serve as a starting point for your project

Add-In Selection | Template Code

Available Add-ins Selacted Add-ins | Advanced]
type filter text
Name Version
4 (> Recommended Add-ins
Startup Code/LDF (10.0)
Analog Devices' MCAPL (1.0.0)
Pin Multiplexing {1.0.0)
SRU Configuration (1.0.0)
4 (> Device Drivers and System Services
> (= ADSP-SChxx EZ-Kit Off-Chip Peripheral Drivers
» & On-chip peripheral drivers
» £ System Services
4 (= Middleware
» = RTCS
4 (= Software Modules
» & Audio Processing
. Advanced Filter = Expand All & Collapse All @ Remove

Please expand this categery to see its associated Add-ins

Do not suppert managed Add-ins in this project

@ Canee

In the CCES menu bar, click Project->Build Configurations->Set Active->Release. The Release Build makes
the project use release version libraries and no debug information included.




In the CCES menu bar, click Project-> Properties. In the left column of the dialogue window, select C/C++
Build->Settings, then select Static Library in the tab Build Artifact. Click OK.

" Properties for Biquad_Corel =] @

type filter text Settings oo
Resource

Builders
4 G/ Build Configuration: |Release [ Active ] ~ | [Manage Configurations..|

Build Variables
Environment
Logging
Settings

i Tool Settings | [ Processor Settings Build Steps Build Artifact | [ Binary Parsers | @ Error Parsers

Artifact Type Static Librany -

Warnings
C/C++ General Artifact name: ${ProjName} -

Project References
Run/Debug Settings

Artifact extension;  dib -

Qutput prefix -

@ [ K ] ‘ Cancel ‘

Copy the file, adi_ss_extmod.h, from “C:\Analog Devices\SoftwareModules\SigmaStudioForSHARC-SH-
Rel3.9.0\Host\Include" to the project src folder. Then you should see it in the CCES Project Explorer
window.

Open “Biquad_Corel.c” and add “#include "adi_ss_extmod.h"”. The header file includes necessary Sigma
Studio related declarations. After that, remove main function, which is not used in the future.

Step 2: Create wrapper functions and develop algorithms

SigmaStudio modules can be of two types: Modules supporting sample/stream processing and
Modules supporting block processing. This instruction will describe how to create plugins for block
processing. The sample based processing uses a similar approach but different wrapper functions and
arguments.

The entry-point function must have a prefix ‘BPROCESS_’ to indicate that it is a block processing Plug-In
function for SigmaStudio. Sub-functions in the source file which are referenced only from the main Plug-
In function or other sub-functions need not follow any convention. The general prototype of a block
processing Plug-In entry-point function is as shown below.

void BPROCESS_<algorithm_name> (SSBlockAlgo* pBlockAlgo)

In addition to the process function, block Algorithms can also have an initialization function.
Initialization functions are used to initialize the Module in case of decoders and 3rd party post
processing Modules. The function name must have the prefix ‘INIT_ ' to indicate that it is the
initialization function of the Module. The general prototype of a block processing Plug-In
initialization function is as shown below.

void INIT_<algorithm_name> (SSBlockAlgo* pBlockAlgo)

Create two functions in “Biquad_Corel.c”, void BPROCESS_Biquad (SSBlockAlgo* pBlkAlgolnfo) and void
INIT_Biquad (SSBlockAlgo* pBlkAlgolnfo), in compliance with previous requirements.

The struct, SSBlockAlgo, is the interface between Sigma Studio libraries, which is a part of Sigma Studio
framework/firmware and runs on Sharc cores, and the custom audio algorithms, as shown below.

typedef struct _SSBlockAlgo



int32_t
int32_t
Block
Block

int32_t
int32_t

void
float32_t
float32_t
float32_t
float32_t
float32_t
float32_t
int32_t
float32_t

} SSBlockAlgo;

nInputs; /*
nOutputs; /*
*pInputs; /*
*pOutputs; /*
nGrowth; /*
nGrowthB; /*
*pParam; /*
*pState; /*
*pScratchDM; /*
*pScratchPM; /*
*pStateB; /*
*pStateC; /*

*pExtPreState; /*
*pExtSymbols; /*
*pSharedMem;

Number of input pins */
Number of output pins */
Pointer to array of block i/o mem structure */
Pointer to array of block i/o mem structure */

Indicates growth count */
Secondary growth count */

Pointer
Pointer
Pointer
Pointer
Pointer
Pointer
Pointer
Pointer

The complete algorithm function is shown below.

to
to
to
to
to
to
to
to

parameter memory */

state memory */

scratch in DM memory */

scratch in PM memory */

state memory B */

state memory C */

extended precision state memory */
symbol address table */

/* Pointer to shared memory buffer in L2 */

void BPROCESS_Multi_Tap_Delay (SSBlockAlgo* pBlkAlgoInfo){

float32_t *params = (float32_t*)(pBlkAlgoInfo->pParam);
int32_t nDelaylLineSize = (int32_t) (params[@]);

int32_t WritePos = (int32_t)pBlkAlgoInfo->pState[0];

float32_t *pInput
int32_t nBlockSize

= pBlkAlgoInfo->pInputs[@].pSamples;
= pBlkAlgoInfo->pInputs[@].pBlockProperties->nBlockSize;

int32_t RepCount = pBlkAlgoInfo->nGrowth;

nDelaylLineSize += nBlockSize;

float32_t *DelaylLine = pBlkAlgoInfo->pStateC;

for(int32_t loopcount = ©;loopcount<nBlockSize;loopcount++, WritePos++){

}

if (WritePos>=nDelaylLineSize)

WritePos-=nDelaylLineSize;

DelayLine[WritePos%nDelaylLineSize] = pInput[loopcount];

pBlkAlgoInfo->pState[@] = (float32_t) WritePos;

for(int32_t index = ©; index < RepCount; index++){

int32_t tap

= (int32_t) pBlkAlgoInfo->pInputs[index+1].pSamples[@];

if (tap > nDelayLineSize-nBlockSize)

tap = nDelaylLineSize-nBlockSize;



int32_t ReadPos = WritePos - nBlockSize - tap;
if (ReadPos<®)
ReadPos += nDelaylLineSize;

float32_t *pOutput= pBlkAlgoInfo->pOutputs[index].pSamples;

for(int32_t loopcount = 0;loopcount<nBlockSize;loopcount++, ReadPos++){
pOutput[loopcount] = DelayLine[ReadPos%nDelaylLineSize];

}

}
Step 3: Create XML file

The Module XML file is an input to the Algorithm Designer and contains the source definitions for the
Module which includes name and path of the module binary, parameter details, pin details etc. Each
XML can contain Module source definitions for one or more Modules. The following items are included
in the source definition.

e Name, path and target processor of DLBs of the Module (ADSP-SC5xx).
e List and details of all the runtime parameters of the Module.
e Details of the input and output pins.

The following is an example of multi_tap_delay module.

<?xml version="1.0" standalone="true"?>
- <SS4SH version="3.9.0.0" description="SigmaStudio for SHARC Algorithm Designer" name="ss4sh_module_xml">
- <module name="Multi_Tap_Delay" block="TRUE">
<dlb name="Multi_Tap_Delay.dlb" path="..\Project\Release\" embed="FALSE" target="ADSP-SC58x"/>
<parameter name="DelayCount" format="FLOAT" isbuffer="NO"/>
<pin direction="INPUT" type="DATA"/>
<pin direction="INPUT" type="CONTROL"/>
<pin direction="OUTPUT" type="DATA"/>
</module>
</SS4SH>

The delay module has one parameter for users to control, which is delay line size. Delay tabs are wired
into the module as input pins that have type of “control”. Please note the sequence of parameters in the
XML determines the sequence in the parameter buffer that is passed to the wrapper function. So does
the input/output pins (buffers) sequence in the XML file.

Step 4: Design graphic user interface

Algorithm Designer, a component of Sigma Studio, is used in integrating externally developed Algorithms.
In the Algorithm Designer, users design controllable interface that connects to the dlb file generated in
the previous step. Once the design is finalized, Algorithm Designer generates DLLs (Dynamic Link Libraries)
which can be used by Sigma Studio for SHARC for redistributing the Plug-In module.

Open Sigma Studio and Click Action->Launch Algorithm Designer in the menu bar. In the upper-left
window, External Modules, click Load Source to load in Multi tap delay xml file.

In the upper-middle window, Design Form, drag and drop in the widget, Numeric UpDown, from the upper
right window, Toolbox. Then users could modify the widget properties in upper right most window,



Properties. In order to match actual maximum size in processor memory, we set maximum to 10000,
minimum to 0 and value to 5000 in the Properties.

} External Modules 7 Design Form | - || Toolbex 2 ||} Properties 1
Modules || ‘Windows Forms 41|
TabSto| True -
List of modules defined in <ML Sigmatudia Confrals Visible ; True
k 2 Data
Button (DataBindings)
Hexadecimal TextBox DecimalPlaces 0
P Increment 1
@ Knobw) Text Maximum 10000
et Minimum i
£5 Mumeric UpDown
* HumericTextBox Tag
ThousandsSep False
& Slider Advanced B Design
@ Slider Simple (Name) myNumericUpDy
@ Spin Text Generatehemk: True
B switch Locked False
B2 Table hodifiers Private =
Focus
: Layou
B Misc
ValueDouble 5000 o
Layout
Load Sour Felease Lock

Click Multi_Tap_Delay in Modules, then set pin names to “Input Signal”, “Delay Tap”, and “Delayed Input”
accordingly. Their sequence is derived from the XML file.

Properiies n
- InQutPin Collection Editor @
EEN
= I/0 Pins Members SharcDesigner.nOuFin properties:
Input 2 SharcDesigner InOutPin s
SharcDesignar nCu + 54}
Qutput 1 1| SharcDesigner.nCutPin . ‘
=] PinLabel InfCut Pin Labels -] 2| SharcDesigner.InCutPin + Sliiequired .
Finlnd SharcDesigner.InO Cabe] Input Signal
Finln1 SharcDesigner.InO
FinQutd SharcDesigner.InO| InQutPin Collection Editor @
E Misc
FileMame Members SharcDesignernOutPin properties
ModuleMame  Muli_Tap_Delay 0[SharcDesignarnOuiPin ~ JH’ |
il SharcDesigner nCutPin 5 Required
2 | SharcDesigner.InCOutPin * equire:
Label Delay Tap
InQutPin Collection Editor @

Members: SharcDesigner.InOutPin properties:

+ B
= Required
+ Label Delayed Input

0| SharcDesigner.InOutPin
1| SharcDesigner.InOutPin
PinLabel SharcDesigner InOutFin

In the lower-left window, Parameter Control->Runtime Parameters, add a variable, and rename it “size”,
in Variable Control. We put 0, 10000, 1 and 5000 in Min, Max, Step and Value respectively.

Parameter Control

Default Parameters | | Runtime Parameters | Memaory Reguirement

Watiable Control | Buffer Control |

Add tem [

Usertariable tin Max

Step Value

size 0 10000 1

=y

S000

The next step is to connect the “Numeric UpDown” widget to the created variable “size”. Click mouse right

button on the “Numeric UpDown” widget in the Design Form. Choose Assign and you should see a similar

window shown below. Set Control Action to CheckedChanged and Run-Time Parameter to the variable,
enable. Click Apply.



Parameter Assignment @

Control Action

“alueChanged -

Fun-Time Parameter Settings Name

Gain
Frequency
OnOft
Lewvel

1 »

Boost
HoldTime
DecayTime =

Custom MName:

myMNumericlpDownl_Level

I Apply ‘ I Cancel I

To connect the widget to the parameter “DelayCount” in the dlb file, in the lower-left window, Parameter
Control->Default Parameters, put in the variable “size”, in Formula / Static Value, as shown below.

Parameter Control L)

Default Parameters | Runtime Parameters | Memory Requirement
Farmulas / Values

werify Equations

Parameter Forrmula / Static Value Format Safeload  Mew Group

Delay Count size Float I:‘ |:|

The custom module requires State and Scratch memory in execution. Users should calculate memory size
based on actual needs. The delay example demands two variables for storing the write and read pointers,
which is allocated in State memory and multiple local variables, which is allocated in Scratch memory, as
shown below. The allocated memory must be equal or greater than the actual needed memory. The State
C memory locates on external memory and will be used for hosting delay line buffer. Its size need to be
equal or greater than the maximum value 10000 we put in the widget.

Parameter Conirol q

Default Parameters | Runtime Parameters | | Memory Reguirement

Werify Equations

Type of Memary Size - Formula/Static Value

State 10
state B 0
State C 10500
State [Ext Fre) 0
Serath [PH) 20

Seratch (D) 20

There are a few general rules for memory allocation:

e All global variables/buffers/tables accessed from an Algorithm are shared across instances of all
the Algorithms inserted in the schematic.
e Code and data can be placed in any section.



e Only extended precision state memory is supported. Tables or parameters cannot be in extended
precision.

e Extended precision access must be cleared at the beginning and restored before exiting if the
Plug-In uses either State B or State C memory buffers. This is because Applications may place the
32-bit state memory buffers in the same block as the Extended Precision state memory buffer.

e Since the input buffers of a Plug-In can be used, with the help of a T-connector, by many
subsequent Modules in a Schematic, care should be taken to preserve the input buffers and to
avoid overwriting of these buffers.

o If there are 2 functions with the same name defined in a single file, the linker gives a “Multiply
defined symbol” error when the schematic which uses the function is link-compile-downloaded.
If the functions with same name are defined in different files, the linker doesn’t throw any error
during the schematic compilation and linking. It uses whichever function definition it finds first
during linking. Hence, it is advisable to use unique function names if it is not intended for the
functions to be shared across modules or with the target application.

In addition, users should provide some basic information about the custom algorithms, in the lower-right
window, Settings, as shown below. Please note Tree Toolbox Category decides where to find the custom
algorithm module in Sigma Studio Toolbox.

;Saltingﬁ
Toolbox Setiings | Growth & Add Settings | Assembly Info | Cell DLL Info

MName: Exarnple: "Addition"

Multi_tap_delay
Schematic Cell Name: Example: "Add"
Multi_tap_delay
Toaolhox Description Exarnpla: "Adder"
bulti_tap_delay
Toolbox Tooltip Example: "Add 2 signals"
Delay input signal by taps
Tree Toolhox Category: Exarnple: "Custarn Algotithrn s Adder”

Custom Algorithms Multi_tap_delay

This module is created with one input channel, one delay control tab and one output channel. If we
allow the module to grow more channels, we should configure it in “Growth & Add Settings”, as shown
below. The number of delay control taps and delay outputs can go up as many as four pairs or down as
few as one pair.



Settings

Toolbox Settings | | Growth & Add Settings | AssemblyInfo | Cell DLL Info
Growth | 20 Growth | Misc

Growth Mode Growth Count
(L) Mane 1 = Minimum Growth
(@) Single Control = )
4 2 Maxirnurm Growth

() Multi Contral - Vertical

() Multi Contral - Horizontal Growth Pins

Additional Input Pins

Al

i3 Additional Outout Pins

Step 5: Generate Dynamic Link Libraries and Load in Sigma Studio

In the Algorithm Designer menu bar, click Action->Generate Assembly, to generate the dll file. In the
Sigma Studio menu bar, click Tools->Add-Ins Browser. In the browser window, click Add DLL icon to add
the new dll file, as shown below.

87 Adellns [E== ol =

File
hel = D

| AADlvirtual.dil -

Z| AAutoFilterDesigner.dil

Z| ABeamFormingarray. dil

V] \HDS%_DEMO.dI

V] y35Ma529.dll

V] y55M3515.dll

V] y55M3ss2.dll

V] ATCRIP.dI

z| Aviirualinterface. dil

V] AZoltzerFilterdil

:l Chanalog Devices\SoftwareModules\SigmaStudioForsHARC-5H-Rel2 2 D\Host DL SharcPubLib.dil

:| Chanalog Devices\SoftwareModules\SigmaStudioForSHARC-5H-Rel2 2 M\Host DL Sharchodules.dil

:‘ Chanalog Devices\SoftwareModules\SigmaStudioForSHARC-5H-Rel2. 2 D\Host DLL\SharcDesigner.dll

z‘ Chanalog Devices\SoftwareModules\SigmaStudioForSHARC-5H-Rel3.9.0\Host DLL\SharcPubLib.dll 3

z‘ Chanalog Devices\SoftwareModules\SigmaStudioForSHARC-53H-Rel3.9 0\Host DL\ SharcModules.dll

haloo ices\SoftwareModules\SigmaStudioFarSHARC-5H-Rel3 8 I\Host DLUASharcDesigner dil
i n Mo \ulti_Tap_| i Tap_D |

After creating a new SC-58x project in Sigma Studio, the new module could be seen in the Tree Toolbox,
ADSP-SC58x, Custom Algorithms, as shown below.

Tree ToolBox 1 x
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